I have a class that encrypts, decrypts, hashes and signs. In the future it may implement something else too, but my question is that 开发者_如何学运维what would that class be called. Currently I call it Encrypter, but it really does things that's not about encrypting. I have thought about the term Crypto, but I am not sure if that's what people usually use/think.
It sounds like you might want to break up your single class into multiple classes, one for each major purpose:
- encrypting
- decrypting
- hashing
- signing
- signature verification
Then you can collect these classes into a library or module (terminology depends on what language you're using).
I would call it OpenSSL. Hah, no but seriously now Crypto
is a good name for it i would also throw in a method to make a Cryptographic Nonce and a String2Key function, especially if you are using "passwords" for symmetric encryption. I am glad you didn't call hashing a form of encryption, because they are very different.
Call it...
a CrytoManager or CryptoService?
or maybe...
an EncryptionManager ?
or a CryptoUtility class ...
精彩评论